FAQs - Compatibility

We are constantly working on improvements so that we can provide everyone with the ultimate user experience in any browser. Unfortunately, this is not 100% up to us, it's important to have the latest version of the browser of your choosing. In the following list you will see our recommendations:

For an optimal building scenario, we recommend working with:
  • Google Chrome

Other supported browsers, but that may present performance issues:
  • Mozilla Firefox
  • Safari
  • Internet Explorer / Edge
This is subject that the overall usage of a version by our customers is above 1% of the total usage.

Usable browser by visitors:
  • Google Chrome
  • Mozilla Firefox
  • Safari
  • Internet Explorer / Edge
This is subject that the overall usage of a version by our customers is above 2% of the total usage.

Currently we don't ensure a full support for Internet Explorer/Edge or any mobile browser with the Landbot platform.


How did we do?